Back to overview
Resolved
Degraded performance on API
Sep 8, 2026 at 7:45am UTC
Affected services
API
Resolved
Sep 8, 2026 at 10:18am UTC
We have resolved the degraded performance on the Board APIs and have been monitoring the situation for the past hour and seen no more issues.
Affected services
Created
Sep 8, 2026 at 7:45am UTC
We're currently investigating the degraded performance on our Board APIs.
Affected services